Great Ideas. Always Flowing.

We are not happy until you are happy. Client satisfaction guaranteed. Whatever your needs and requirements, we have the skills and resources for the job!

Quick login...


Or... now make it easy with Facebook Integration
Connect via Facebook



Top Sellers

Frustrated over the lack of customization for your user's registration fields? Dynamically setup your DNN Portal with custom registration fields, layout, questions, and other core integration options......

Ultra Video Gallery is a brother product of Ultra Media Gallery, UVG allows you to upload videos in various format and automatically encode them to flv or H264 format, you also can add videos from internet or record live videos from your webcam.

Build high performance, completely customizable data-entry forms and views driven by your DNN and external databases. New built-in tools make it a snap to quickly create data entry forms, data views, and even database tables. Plus, add your own HTML, CSS, Javascript, SQL commands, stored procedures,

The most advanced DotNetNuke shopping cart on the planet. Easy to use e-Commerce, Secure Shopping Cart Software and SEO friendly. B2C / B2B Ecommerce Sites.

One stop solution for events calendar and events registration! FREE DOWNLOAD is available now!

Dynamic Login Template Issues
Last Post 10-02-2013 09:21 AM by Kevin Terry. 13 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
t-boneUser is Offline
river guide
river guide
Posts:77
Avatar

--
08-02-2013 08:59 AM
    New to Dynamic Login.. I have noticed 2 bugs (possibly bugs).

    I did the initial setup.. on the template screen I didn't see anything.. so I clicked "restored default template".. boom! There's the template. I then added some text to it outside of the default template table, just to verify that my login page displayed it.. okay.

    Logged back into DNN to continue editing the template, but the template was empty.. If I clicked on the "basic text box" radio button, then click back on "rich text box", the template I created appears... strange & painfully slow... I can work through that though.

    My biggest problem though is when I make a change to the template, none of the changes are reflected in the login screen!! I log out, go to my login (as unauthenticated/not logged in) and it displays how the form looked initially.. I cleared my history/cache.. checked in 3 different browsers and nothing... the odd thing is, when I log back in.. go to the template.. click "basic text box".. then "rich text box" (to view the template info), it displays all of my changes!!!

    Any help is appreciated!!

    Versions i'm working with (below):
    DNN: 7.00.04 (180)
    Dynamic Login: 4.10.62


    t-boneUser is Offline
    river guide
    river guide
    Posts:77
    Avatar

    --
    08-02-2013 10:12 AM
    Attaching 2 screen shots of what i'm talking about..

    First is the Template edit screen with some TEXT highlighted in yellow/red font.. it should show on the 2nd screen shot.. but does not. Again, i've cleared cache and tried it on 3 different browsers (IE, Chrome, FF).. none show the yellow/red text.

    The odd thing is, the template editor shows it!!!

    001_Dyn_login_template_edit.pdf

    t-boneUser is Offline
    river guide
    river guide
    Posts:77
    Avatar

    --
    08-02-2013 10:13 AM
    .. wouldn't let me upload 2 file at a time.. here's the 2nd screen shot showing the normal view of the login (as if a user isn't logged in yet)..

    Dyn_login_view_normal.pdf

    t-boneUser is Offline
    river guide
    river guide
    Posts:77
    Avatar

    --
    08-05-2013 07:10 AM
    ..Using IE Script debugger.. found there are some additional issues (or related/contributing issues to the Dynamic Login bug(s) mentioned above)..


    malformed "id" tag... no closing double quote for the link id..

    See attached.

    Screen_Clip_Script_Errors_Dynamic_Login.pdf

    t-boneUser is Offline
    river guide
    river guide
    Posts:77
    Avatar

    --
    08-05-2013 09:45 AM
    ..crickets..


    CandaceUser is Offline
    river guide
    river guide
    Posts:2431
    Avatar

    --
    08-05-2013 10:30 AM
    Hi t-bone,

    Let me ask you a few questions:

    1. Does your page have both DL and the standard DNN Login module on it?

    2. Is the DL module visible to all users?

    3. How are you getting to the DL page as unauthenticated -- by the actual URL or by clicking on the login button? Can you verify that it's going to the right page?

    Thanks!
    Candace


    t-boneUser is Offline
    river guide
    river guide
    Posts:77
    Avatar

    --
    08-05-2013 10:44 AM
    1. Yes.. I didn't think of that.. but yes it was on there, but I deleted it just now.. still doesn't affect the page rendering issues i'm experiencing. I'll remove the DL module and re-try it on a blank page to see if that makes a difference.

    2. Yes.. it's visible to all users. (page & module)

    3. Right now, i'm just typing in the URL.. we do not want it tied to the normal DNN login or to redirect to the home page.


    CandaceUser is Offline
    river guide
    river guide
    Posts:2431
    Avatar

    --
    08-05-2013 11:28 AM
    Thanks for the responses. Hmmm.... that's very strange. We do want the standard DNN login module on the same page so please do not delete that (or at least, put it back).

    Let us know what happens with the blank page. Also, do you see any related errors in Admin, Event Viewer?

    Candace


    t-boneUser is Offline
    river guide
    river guide
    Posts:77
    Avatar

    --
    08-05-2013 11:37 AM
    Adding the DNN login back to the page (plain.. we did add some JS/css changes to the one I removed earlier) seems to have fixed the issue with the template editor displaying properly... without clicking "basic" then "rich"..

    But I still don't see any changes I make to the template after saving them.. clearing cache/other browsers. It is strange cause I do see them in the template editor, just not in the login view (unauthenticated).

    Nothing odd showing in the event viewer.. Nothing related to our page.


    t-boneUser is Offline
    river guide
    river guide
    Posts:77
    Avatar

    --
    08-05-2013 11:40 AM
    ..spoke too soon. The template editor worked fine the first time.. would display all tokens in it. But I just went back in to view it/edit it.. and I have to click "basic" then "rich" to get it to come up.


    CandaceUser is Offline
    river guide
    river guide
    Posts:2431
    Avatar

    --
    08-05-2013 02:55 PM
    Ok, I guess we need to look under the hood now. I'll send you a response to one of the Contact Forms. Thanks!

    Candace


    Kevin TerryUser is Offline
    new to the springs
    new to the springs
    Posts:2
    Avatar

    --
    10-02-2013 06:02 AM
    T-bone, I have this same issue where the changes I make are not reflected in the Dynamic Login module (v4.10.62 on DNN 6.2.5) when I save the template changes. I also am viewing my changes in multiple browsers and recycling the app pool and dumping the cache with each Login template change. But I still see a blank Login module. Only changes I make to the module through the Settings are visible.

    One time I was able to see a change to the Login module and upon a refresh after some changes the login boxes vanished again.

    My programmer friend discovered the malformed tag:
    Were you able to get yours working correctly? This is frustrating. I'm trying to add the LinkedIn login functionality and it worked once, then vanished. Thank you.


    t-boneUser is Offline
    river guide
    river guide
    Posts:77
    Avatar

    --
    10-02-2013 09:11 AM
    Kevin,

    I believe it's a bug in the dynamic login module.. I haven't heard anything about it since August... I've posted a few other topics in here and haven't heard anything on those either.. beginning to wonder if DS is on a long vacation..

    Candace (from DS) did respond in August with a "Work-Around".. and said she'd be sending it up for review to the programmers.

    ---Candace's email to me about MY site---
    Here’s a summary of what I found:

    1.  The additional text shows up when I add it from Initial Settings right after I loaded the module.

    2.  Once I was done with Initial Settings/Setup Template and I hit Exit Control Panel, no other edits reflected on the module for unauthenticated users.  HOWEVER, if you check on the template again and click on Basic, the added text has been saved.

    3.  I was able to get to show after I went to Host > Host Settings and hit Restart Application. That tells me that that there may be a delay in the server somewhere but I’m not sure yet where that is.



    -----------


    Obviously this isn't ideal for a site that has many active users.. but it's the only solution they've offered and it does work just fine, but if your site is active.. expect some complaints if you have to restart the DNN app a dozen or so times just to see what your changes look like.


    Good luck!


    Kevin TerryUser is Offline
    new to the springs
    new to the springs
    Posts:2
    Avatar

    --
    10-02-2013 09:21 AM
    Thanks T-bone! Luckily, my issue is still delegated to my test site and not my production site. But, should I want to update my production login form it looks like I'll have to tip toe my way through. I bought this module back in the spring so I was hoping that there would have been a fix release for it by now. Thanks again.


    You are not authorized to post a reply.


     
     

    Join our mailing list...

    Get current news and events the easy way
     
     
       
    Subscribe Me

    Recent Blogs...

     
    Copyright 2005 - 2011 by Data Springs, Inc.