Great Ideas. Always Flowing.

We are not happy until you are happy. Client satisfaction guaranteed. Whatever your needs and requirements, we have the skills and resources for the job!

Quick login...


Or... now make it easy with Facebook Integration
Connect via Facebook



Top Sellers

Frustrated over the lack of customization for your user's registration fields? Dynamically setup your DNN Portal with custom registration fields, layout, questions, and other core integration options......

Ultra Video Gallery is a brother product of Ultra Media Gallery, UVG allows you to upload videos in various format and automatically encode them to flv or H264 format, you also can add videos from internet or record live videos from your webcam.

Build high performance, completely customizable data-entry forms and views driven by your DNN and external databases. New built-in tools make it a snap to quickly create data entry forms, data views, and even database tables. Plus, add your own HTML, CSS, Javascript, SQL commands, stored procedures,

The most advanced DotNetNuke shopping cart on the planet. Easy to use e-Commerce, Secure Shopping Cart Software and SEO friendly. B2C / B2B Ecommerce Sites.

One stop solution for events calendar and events registration! FREE DOWNLOAD is available now!

Image won't show up
Last Post 08-20-2013 02:43 PM by Paul Montgomery. 16 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Drew AllenUser is Offline
new to the springs
new to the springs
Posts:2
Avatar

--
12-02-2010 05:32 AM
    Hi all,

    I am not sure what I am doing wrong. I have gone into my DNN profile and uploaded an image to the Photo section via users-manage profile. I have then gone to the User Detail Template and added the [photo] tag. Right now all that shows up is the number 7106.

    What exactly am I doing wrong here?

    Thanks,
    Drew
    Chad NashUser is Offline
    Posts:5260
    Avatar

    --
    12-02-2010 09:29 AM
    Hi Drew - Well actually all DNN does when you save your profile image is saves the actual File ID number to that file within the file system. This can make it difficult for other systems to actually pull out the real file and it has to be handled via code.

    The good news is that we did code for this

    So, you should be able to go to module configuration and define all of your settings there for the [UserImage] token. [UserImage] is a specific token within the Dynamic User Directory module that should look at your settings there in module configuration where you can choose things like the thumbnail size, if you want an alternate profile image if a user doesn't have one, etc...

    Thanks,

    Chad
    Drew AllenUser is Offline
    new to the springs
    new to the springs
    Posts:2
    Avatar

    --
    12-02-2010 09:39 AM
    Thanks for the quick reply Chad.

    The thing is I am using the [photo] token instead of [userimage] because every time I use that one it creates an issue were I get logged out continuously.

    I have a field in the Dynamic Registration that allows the user to upload an image and the module configuration referencing this. What should the "User Image Field" contain to reference this? Is it Photo?

    Thanks,
    Drew
    Chad NashUser is Offline
    Posts:5260
    Avatar

    --
    12-03-2010 09:47 AM
    Hi Drew - Well I do know that the [photo] token itself is only going to render what DNN stores as the ID for the file (it references the FileID which references the Files table which has the directory and file name in it etc...)

    So the bigger issue is what the [userimage] token isn't working for you. We might need you to set us up with host rights or open a support ticket so that we can review why you are getting logged out when referencing the user image field token. It should be taking your settings, finding the FileID number for that user and finding the actual file name, displaying a thumbnail of that file based on the thumbnail settings etc...

    Is this on a local host environment? Is this using a standard URL such as www.site.com or something like www.site.com/anotherdirectory?

    If you open a support ticket we should be able to do some research and debugging on why the user image token isn't working. I do know that you will need it and won't be able to go the direction you are going with the other token.

    Thanks,

    -Chad
    536373User is Offline
    skipping stones
    skipping stones
    Posts:5
    Avatar

    --
    01-27-2011 04:43 PM
    Chad, I'm experiencing a similar situation as the OP with the number displaying when I use [photo] . When I use [userimage], for users who do indeed have images the "no user image" is displayed (/DesktopModules/Dynamic User Directory/NoUserImage.jpg). Users who really don't have an image have the browser's missing image displayed. Can you provide examples?

    Please include some HTML and any values that should be in the configuration settings section titled:
    "User Image / User Online Image / User Offline Image"
    • Integration Type
    • User Image Field
    • Image Location
    • Image Type

    Thanks, I'm trying to get this working but based on your description I'm not sure how it matches up to those fields. A concrete example might help.
    For example, I've looked at the file system for the user images, and they have real names, not numbers, so I don't know what path to use. (since apparently it isn't Portals/[portalid]/Users/[userid]/[userid]/[userid] which is what I guessed.

    I'm on DNN 5.6.1 and the trial module that I downloaded tonight.
    Robert ManjoneyUser is Offline
    going with the flow
    going with the flow
    Posts:33
    Avatar

    --
    06-20-2011 01:57 PM
    I'm seeing the same behavior. Profiles with photos are displaying as "NoUserImage.jpg".
    rayUser is Offline
    skipping stones
    skipping stones
    Posts:8
    Avatar

    --
    09-09-2011 12:06 PM
    Chad,

    This is not well documented in your UM.  You have 4 fields which you try to use to pull the file out of a users profile and populate in your display.

    I believe that I should use [userimage] in the template.  Then your module should use the information in:

    Integration Type:
    User Image Field:
    Image Location:
    Image Type: 

    and find the picture and populate it in the display.  The problem is that you have not done a very good job describing what these fields need to be.  For instance:  I select DNN Profile because I haven't installed DNN Dynamic registration yet.  For user inmage field I pick "Photo" because that is the field used in their profile to upload an image.  Now things get tricky - I have no idea what your module needs in the Image Location filed.  For instance does /xxxxx/Portal/0/Users make sense?  This is the root directory of where the images are being uploaded to when users update their profile.  Where should that path be referenced from?  Do I need the full path on the hosting server?  Don't know and haven't guessed right yet.  Then the fourth field - does it matter whether I select thumbnail or full image?  I have a JPG there right now.

    Someone else in this thread commented that an example from your side would be nice.  Where you fill int those 4 fields for a typical DNN installation (ie. not using the dynamic registration module)

    Help
    Chuck RizzioUser is Offline
    new to the springs
    new to the springs
    Posts:3
    Avatar

    --
    03-28-2012 04:16 AM

    Wow, now I'm concerned.  The last couple of posts are 6 months old and I see no replies and there still is no documentation on the photos features.

    We just purchased Dynamic User Directory yesterday and I installed and started configuring last night.  Everything seemed straight forward until I tried getting the user photos to work.  I am experiencing the same problem as the last two posts.  Please help!

    Can we please have some explanation of the fields in the "User Image / User Online Image / User Offline Image" section of the COnfiguration screen?  Also, an example and updated documentation would be greatly appreciated.  The example could be just the templates used on your demo site and in the video.

    Thanks,

    Chuck

    Chuck RizzioUser is Offline
    new to the springs
    new to the springs
    Posts:3
    Avatar

    --
    03-28-2012 08:42 AM

    I did some more digging and I am seeing what appears to be an invalid URL. I have a feeling that this is related to what others have posted regarding not knowing what entries to put in the "User Image" fields on the module configuration screen. Below is the URL that is seen when right-clicking the missing image and looking at the properties for the object.  Note the "double slashes" just before "DUDThumbnail.ashx".

    ...DesktopModules/Dynamic%20User%20Directory//DUDThumbNail.ashx?width=150&height=150&Image=Users/102/02/102/Chuck-Rizzio-200.jpg.

    Below is a screen-shot of what I am seeing.

    Illustration

    Any help would be greatly appreciated!

    Chuck R.

    NebRefUser is Offline
    river guide
    river guide
    Posts:91
    Avatar

    --
    03-28-2012 08:56 AM
    I was having this problem a couple of months ago - I couldn't find what I supposed to put in the User Image fields. Chad referred me to this post which was very helpful:

    http://www.datasprings.com/news/blo...rectory-pr

    Currently, this is what I have entered and everthing seems to be working:

    Integration Type: Dynamic Registration
    User Image Field: imgUpload
    Image Location: /portals/0/DynamicRegistration_Images/
    Image Type: Thumbnail with full image hyperlink

    As I said, these are my settings and it works well. Good luck

    Jim
    NebRefUser is Offline
    river guide
    river guide
    Posts:91
    Avatar

    --
    03-28-2012 08:57 AM
    Sorry, I just noticed that you aren't using Dynamic Registratoin and as you can see, my site does. Maybe what I just gave you doesn't help much. Sorry, again.

    Jim
    Chuck RizzioUser is Offline
    new to the springs
    new to the springs
    Posts:3
    Avatar

    --
    03-28-2012 09:17 AM
    Jim

    THANK YOU, THANK YOU, THANK YOU!

    You were right in that we are not using the Dynamic Registration module but the article you refered to solved the problem. Not knowing what to put into the User Image fields I left most blank. The article explained each of the fields (an added bonus). I added "/Portals/0/" for the "Image Location" and BINGO it worked.

    Thanks again!

    Chuck
    CandaceUser is Offline
    river guide
    river guide
    Posts:2431
    Avatar

    --
    03-28-2012 07:19 PM
    Thanks for pointing out the blog post, Jim! I was about to refer Chuck there when I noticed your post.

    Chuck, thanks for bringing it up and for letting us know that the article was helpful. For those following this post, here's the link to the blog again:

    http://www.datasprings.com/news/blo...rectory-pr


    Candace
    Trent SmithUser is Offline
    skipping stones
    skipping stones
    Posts:13
    Avatar

    --
    04-19-2012 06:16 AM
    I cannot get the photo to appear.

    1. I'm not using dynamic registration but rather default dnn registration.

    2. I've read the recommended blog post related to this issue.

    3. My Image SRC path ='s http://www.hanfra.org/Portals/0/611 .  As you can see it renders a number and not the image.

    4. What am I doing wrong?


    Chad NashUser is Offline
    Posts:5260
    Avatar

    --
    04-24-2012 05:49 PM
    Hi Trent - I know I responded to your email directly via the Contact Us form however I wanted to respond here as well. Basically the only way to handle the integration options that you are trying to use is to use the very latest version(s) of Dynamic User Directory (we have the current 4.0 version and the upcoming 4.1 version that will be released on Tuesday). These builds allow for the [UserImage] field which can then replace the FileID number into the Filename. Basically DotNetNuke stores all of these profile images as the FileID number (an auto number that is a primary key into the Files table). So... basically this is stored in the UserProfile table as a number and we have to then convert that into a filename.

    Thanks!

    -Chad
    NebRefUser is Offline
    river guide
    river guide
    Posts:91
    Avatar

    --
    12-17-2012 01:14 PM
    Chad:

    As you know, I have been able to integrate Dynamic Registration in such a way that my user images display properly in my pages. However, I recently installed a Social Groups skin which incorporates the hyperlinks bar at the top of every page. This bar includes a profile avatar. My Dynamic Registration image does not appear here - instead I have to go to Admin > User Accounts > Manage Profile, and load the image that way.

    Is there a solution for this so I can have that Avatar load through Dynamic Registration?

    Thanks,

    Jim
    Paul MontgomeryUser is Offline
    new to the springs
    new to the springs
    Posts:1
    Avatar

    --
    08-20-2013 02:43 PM
    I've been experiencing the same problem. I have the /portal/0/ set - but no image appears.

    What gives?

    any real solution to this yet?
    You are not authorized to post a reply.


     
     

    Join our mailing list...

    Get current news and events the easy way
     
     
       
    Subscribe Me

    Recent Blogs...

     
    Copyright 2005 - 2011 by Data Springs, Inc.
     
  • film izle
  • 720 izle
  • film
  • sinema izle
  • film makinesi
  • T�rk�e dublaj film
  • film izle
  • film izle
  • baglan film izle
  • sinema izle
  • 1080 film izle
  • film mercegi